Alaska Software Inc. - Windows 10 recent updates & international characters
Username: Password:
AuthorTopic: Windows 10 recent updates & international characters
Damir HodakWindows 10 recent updates & international characters
on Tue, 30 May 2017 14:44:26 +0200
Hi everyone!
After installing recent updates for windows 10 I can't anymore type
international characters (for croation language: šđčćž) in my alaska
xbase++ aplication.
Still use version 1.90.355 SL1 with Hotfix Rollup 50.
Has anybode same problem?
Had you solved it?

Regards

Damir
Matej JuracRe: Windows 10 recent updates & international characters
on Wed, 31 May 2017 09:15:16 +0200
Hello Damir and greetings from other side of border.

Got a tiny bit of 'herzschlag' and tried a three tiered app on Windows 10 Pro,
64 bit , Release 1703 (freshly installed) Creators Update, runs under current
vmWare Workstation as VM.

Exe compiled with xpp [1.90.355] + express++ & sqlexpress & ot4xb 

- ČĆŠĐŽčćžđš & upper/lower works correctly
- routines to sort data (own) also work correctly
- sql to mysql,postgre,mssql: works after quick test
- .manifest is respected by OS
- r&r and fastreport work too

could not test SSL (libssl, ssleay libcurl. libwget) but those were never
troublesome


So Damir you will have to give more info:
- when you type , do you get {}[]| instead of čćžđšđ (wrong keyboard language)?
- or when you type, instead of čžćčđšš you get rectangles or strange chars
(problem with font)
- you type ĐŠČŽČĆ and nothing happens at all

Greetings, M

So probably it is some windows setting that is screwing you. Can you check
setting for language for non-Unicode applications (as xpp does not have such


Damir Hodak wrote in message news:jaewq67uvzmd.15smdvays0yip$.dlg@40tude.net...
>Hi everyone!
>After installing recent updates for windows 10 I can't anymore type
>international characters (for croation language: šđčćž) in my alaska
>xbase++ aplication.
>Still use version 1.90.355 SL1 with Hotfix Rollup 50.
>Has anybode same problem?
>Had you solved it?
>
>Regards
>
>Damir
Damir HodakRe: Windows 10 recent updates & international characters
on Wed, 31 May 2017 15:21:30 +0200
On Wed, 31 May 2017 09:15:16 +0200, Matej Jurac wrote:

> Hello Damir and greetings from other side of border.
> 
> Got a tiny bit of 'herzschlag' and tried a three tiered app on Windows 10 Pro,
> 64 bit , Release 1703 (freshly installed) Creators Update, runs under current
> vmWare Workstation as VM.
> 
> Exe compiled with xpp [1.90.355] + express++ & sqlexpress & ot4xb 
> 
> - ČĆŠĐŽčćžđš & upper/lower works correctly
> - routines to sort data (own) also work correctly
> - sql to mysql,postgre,mssql: works after quick test
> - .manifest is respected by OS
> - r&r and fastreport work too
> 
> could not test SSL (libssl, ssleay libcurl. libwget) but those were never
> troublesome
> 
> 
> So Damir you will have to give more info:
> - when you type , do you get {}[]| instead of čćžđšđ (wrong keyboard language)?
> - or when you type, instead of čžćčđšš you get rectangles or strange chars
> (problem with font)
> - you type ĐŠČŽČĆ and nothing happens at all
> 
> Greetings, M
> 
> So probably it is some windows setting that is screwing you. Can you check
> setting for language for non-Unicode applications (as xpp does not have such
> 
> 
> Damir Hodak wrote in message news:jaewq67uvzmd.15smdvays0yip$.dlg@40tude.net...
>>Hi everyone!
>>After installing recent updates for windows 10 I can't anymore type
>>international characters (for croation language: šđčćž) in my alaska
>>xbase++ aplication.
>>Still use version 1.90.355 SL1 with Hotfix Rollup 50.
>>Has anybode same problem?
>>Had you solved it?
>>
>>Regards
>>
>>Damir

Hi Matej,
problem is when I type šđč枊ĐČĆŽ I get wrong ascii codes for pressed key.
I attached sample and 2 print screens, one with correct codes and other
with wrong codes (I pressed same keys in both cases, but the result is not
same).
It seems problem exist only in VIO mode. In GUI mode everything is ok.

Do you have installed "2017-05 Cumulative Update for Windows 10 Version
1703 for x64-based Systems (KB4020102)"? I thing this update is cause of
problems. 

Greetings

Damir


WIN10NOTOK.jpg
WIN10OK.jpg
testkey.prg
Matej JuracRe: Windows 10 recent updates & international characters
on Thu, 01 Jun 2017 08:23:05 +0200
Will compile and post results.


Damir Hodak wrote in message news:q8nfsa13en9v$.berma7npqrm2$.dlg@40tude.net...
>On Wed, 31 May 2017 09:15:16 +0200, Matej Jurac wrote:
>
>> Hello Damir and greetings from other side of border.
>> 
>> Got a tiny bit of 'herzschlag' and tried a three tiered app on Windows 10 Pro,
>> 64 bit , Release 1703 (freshly installed) Creators Update, runs under current
>> vmWare Workstation as VM.
>> 
>> Exe compiled with xpp [1.90.355] + express++ & sqlexpress & ot4xb 
>> 
>> - ČĆŠĐŽčćžđš & upper/lower works correctly
>> - routines to sort data (own) also work correctly
>> - sql to mysql,postgre,mssql: works after quick test
>> - .manifest is respected by OS
>> - r&r and fastreport work too
>> 
>> could not test SSL (libssl, ssleay libcurl. libwget) but those were never
>> troublesome
>> 
>> 
>> So Damir you will have to give more info:
>> - when you type , do you get {}[]| instead of čćžđšđ (wrong keyboard language)?
>> - or when you type, instead of čžćčđšš you get rectangles or strange chars
>> (problem with font)
>> - you type ĐŠČŽČĆ and nothing happens at all
>> 
>> Greetings, M
>> 
>> So probably it is some windows setting that is screwing you. Can you check
>> setting for language for non-Unicode applications (as xpp does not have such
>> 
>> 
>> Damir Hodak wrote in message news:jaewq67uvzmd.15smdvays0yip$.dlg@40tude.net...
>>>Hi everyone!
>>>After installing recent updates for windows 10 I can't anymore type
>>>international characters (for croation language: šđčćž) in my alaska
>>>xbase++ aplication.
>>>Still use version 1.90.355 SL1 with Hotfix Rollup 50.
>>>Has anybode same problem?
>>>Had you solved it?
>>>
>>>Regards
>>>
>>>Damir
>
>Hi Matej,
>problem is when I type šđč枊ĐČĆŽ I get wrong ascii codes for pressed key.
>I attached sample and 2 print screens, one with correct codes and other
>with wrong codes (I pressed same keys in both cases, but the result is not
>same).
>It seems problem exist only in VIO mode. In GUI mode everything is ok.
>
>Do you have installed "2017-05 Cumulative Update for Windows 10 Version
>1703 for x64-based Systems (KB4020102)"? I thing this update is cause of
>problems. 
>
>Greetings
>
>Damir
Matej JuracRe: Windows 10 recent updates & international characters
on Thu, 01 Jun 2017 08:54:26 +0200
Scan codes, according to and compared with 'OK' resoults are ok (see
screenshot in attachment), font is wrong, but that is out of scope of problem,
probably missing font file for alaska terminal.

Is there specific reason you are using terminal mode and scanning inkey() SW
in 2017 and cannot be solved by checking OS events?



Matej Jurac wrote in message
news:41e1209c$1c8dfb89$21602@news.alaska-software.com...
>Will compile and post results.
>
>
>Damir Hodak wrote in message news:q8nfsa13en9v$.berma7npqrm2$.dlg@40tude.net...
>>On Wed, 31 May 2017 09:15:16 +0200, Matej Jurac wrote:
>>
>>> Hello Damir and greetings from other side of border.
>>> 
>>> Got a tiny bit of 'herzschlag' and tried a three tiered app on Windows 10 Pro,
>>> 64 bit , Release 1703 (freshly installed) Creators Update, runs under current
>>> vmWare Workstation as VM.
>>> 
>>> Exe compiled with xpp [1.90.355] + express++ & sqlexpress & ot4xb 
>>> 
>>> - ČĆŠĐŽčćžđš & upper/lower works correctly
>>> - routines to sort data (own) also work correctly
>>> - sql to mysql,postgre,mssql: works after quick test
>>> - .manifest is respected by OS
>>> - r&r and fastreport work too
>>> 
>>> could not test SSL (libssl, ssleay libcurl. libwget) but those were never
>>> troublesome
>>> 
>>> 
>>> So Damir you will have to give more info:
>>> - when you type , do you get {}[]| instead of čćžđšđ (wrong keyboard
language)?
>>> - or when you type, instead of čžćčđšš you get rectangles or strange chars
>>> (problem with font)
>>> - you type ĐŠČŽČĆ and nothing happens at all
>>> 
>>> Greetings, M
>>> 
>>> So probably it is some windows setting that is screwing you. Can you check
>>> setting for language for non-Unicode applications (as xpp does not have such
>>> 
>>> 
>>> Damir Hodak wrote in message
news:jaewq67uvzmd.15smdvays0yip$.dlg@40tude.net...
>>>>Hi everyone!
>>>>After installing recent updates for windows 10 I can't anymore type
>>>>international characters (for croation language: šđčćž) in my alaska
>>>>xbase++ aplication.
>>>>Still use version 1.90.355 SL1 with Hotfix Rollup 50.
>>>>Has anybode same problem?
>>>>Had you solved it?
>>>>
>>>>Regards
>>>>
>>>>Damir
>>
>>Hi Matej,
>>problem is when I type šđč枊ĐČĆŽ I get wrong ascii codes for pressed key.
>>I attached sample and 2 print screens, one with correct codes and other
>>with wrong codes (I pressed same keys in both cases, but the result is not
>>same).
>>It seems problem exist only in VIO mode. In GUI mode everything is ok.
>>
>>Do you have installed "2017-05 Cumulative Update for Windows 10 Version
>>1703 for x64-based Systems (KB4020102)"? I thing this update is cause of
>>problems. 
>>
>>Greetings
>>
>>Damir



ScreenShotCurrent.png
Damir HodakRe: Windows 10 recent updates & international characters
on Thu, 01 Jun 2017 10:57:43 +0200
On Thu, 01 Jun 2017 08:54:26 +0200, Matej Jurac wrote:

> Scan codes, according to and compared with 'OK' resoults are ok (see
> screenshot in attachment), font is wrong, but that is out of scope of problem,
> probably missing font file for alaska terminal.
> 
> Is there specific reason you are using terminal mode and scanning inkey() SW
> in 2017 and cannot be solved by checking OS events?
> 
> 
> 
> Matej Jurac wrote in message
> news:41e1209c$1c8dfb89$21602@news.alaska-software.com...
>>Will compile and post results.
>>
>>
>>Damir Hodak wrote in message news:q8nfsa13en9v$.berma7npqrm2$.dlg@40tude.net...
>>>On Wed, 31 May 2017 09:15:16 +0200, Matej Jurac wrote:
>>>
>>>> Hello Damir and greetings from other side of border.
>>>> 
>>>> Got a tiny bit of 'herzschlag' and tried a three tiered app on Windows 10 Pro,
>>>> 64 bit , Release 1703 (freshly installed) Creators Update, runs under current
>>>> vmWare Workstation as VM.
>>>> 
>>>> Exe compiled with xpp [1.90.355] + express++ & sqlexpress & ot4xb 
>>>> 
>>>> - ČĆŠĐŽčćžđš & upper/lower works correctly
>>>> - routines to sort data (own) also work correctly
>>>> - sql to mysql,postgre,mssql: works after quick test
>>>> - .manifest is respected by OS
>>>> - r&r and fastreport work too
>>>> 
>>>> could not test SSL (libssl, ssleay libcurl. libwget) but those were never
>>>> troublesome
>>>> 
>>>> 
>>>> So Damir you will have to give more info:
>>>> - when you type , do you get {}[]| instead of čćžđšđ (wrong keyboard
> language)?
>>>> - or when you type, instead of čžćčđšš you get rectangles or strange chars
>>>> (problem with font)
>>>> - you type ĐŠČŽČĆ and nothing happens at all
>>>> 
>>>> Greetings, M
>>>> 
>>>> So probably it is some windows setting that is screwing you. Can you check
>>>> setting for language for non-Unicode applications (as xpp does not have such
>>>> 
>>>> 
>>>> Damir Hodak wrote in message
> news:jaewq67uvzmd.15smdvays0yip$.dlg@40tude.net...
>>>>>Hi everyone!
>>>>>After installing recent updates for windows 10 I can't anymore type
>>>>>international characters (for croation language: šđčćž) in my alaska
>>>>>xbase++ aplication.
>>>>>Still use version 1.90.355 SL1 with Hotfix Rollup 50.
>>>>>Has anybode same problem?
>>>>>Had you solved it?
>>>>>
>>>>>Regards
>>>>>
>>>>>Damir
>>>
>>>Hi Matej,
>>>problem is when I type šđč枊ĐČĆŽ I get wrong ascii codes for pressed key.
>>>I attached sample and 2 print screens, one with correct codes and other
>>>with wrong codes (I pressed same keys in both cases, but the result is not
>>>same).
>>>It seems problem exist only in VIO mode. In GUI mode everything is ok.
>>>
>>>Do you have installed "2017-05 Cumulative Update for Windows 10 Version
>>>1703 for x64-based Systems (KB4020102)"? I thing this update is cause of
>>>problems. 
>>>
>>>Greetings
>>>
>>>Damir

Hi Matej!
Thank you for your efforts.
I still have some applications in terminal mode. Currently don't have
enough time to convert them to GUI mode.

Miran found a solution for the problem. If I check "Use legacy console"
everything works correctly again.

Thank you again.

Damir
Zupan Miran Re: Windows 10 recent updates & international characters
on Thu, 01 Jun 2017 09:56:36 +0200
Damir Hodak je 30.05. 2017 ob 14:44 napisal:
> Hi everyone!
> After installing recent updates for windows 10 I can't anymore type
> international characters (for croation language: šđčćž) in my alaska
> xbase++ aplication.
> Still use version 1.90.355 SL1 with Hotfix Rollup 50.
> Has anybode same problem?
> Had you solved it?
> 
> Regards
> 
> Damir
> 
 > Yes, I thinh MS change CMD in latest upgrade
Look at the CMD properties for code page for CMD
or use "old" aplications
Pozdrav
Miran Zupan



---
Ta e-pošta je bila pregledana z Avast protivirusnim programom.
https://www.avast.com/antivirus
Zupan Miran Re: Windows 10 recent updates & international characters
on Thu, 01 Jun 2017 09:58:03 +0200
Damir Hodak je 30.05. 2017 ob 14:44 napisal:
> Hi everyone!
> After installing recent updates for windows 10 I can't anymore type
> international characters (for croation language: šđčćž) in my alaska
> xbase++ aplication.
> Still use version 1.90.355 SL1 with Hotfix Rollup 50.
> Has anybode same problem?
> Had you solved it?
> 
> Regards
> 
> Damir
> 
This can help also
Pozdrav


---
Ta e-pošta je bila pregledana z Avast protivirusnim programom.
https://www.avast.com/antivirus


CMD.jpg
Damir HodakRe: Windows 10 recent updates & international characters
on Thu, 01 Jun 2017 11:00:46 +0200
On Thu, 01 Jun 2017 09:58:03 +0200, Zupan Miran wrote:

> Damir Hodak je 30.05. 2017 ob 14:44 napisal:
>> Hi everyone!
>> After installing recent updates for windows 10 I can't anymore type
>> international characters (for croation language: šđčćž) in my alaska
>> xbase++ aplication.
>> Still use version 1.90.355 SL1 with Hotfix Rollup 50.
>> Has anybode same problem?
>> Had you solved it?
>> 
>> Regards
>> 
>> Damir
>> 
> This can help also
> Pozdrav
> 
> 
> ---
> Ta e-pošta je bila pregledana z Avast protivirusnim programom.
> https://www.avast.com/antivirus

Hi Miran!
Your suggestion helped me.
If I check "use legacy console" it works correctly again.
Hope Microsoft (or Alaska) would correct it.
Thank you 

Pozdrav
Damir
Matej JuracRe: Windows 10 recent updates & international characters
on Thu, 01 Jun 2017 11:29:46 +0200
Damir Hodak wrote in message news:1ghf41emcbfxj.s5jsob46mdoe.dlg@40tude.net...
>On Thu, 01 Jun 2017 09:58:03 +0200, Zupan Miran wrote:
>
>> Damir Hodak je 30.05. 2017 ob 14:44 napisal:
>>> Hi everyone!
>>> After installing recent updates for windows 10 I can't anymore type
>>> international characters (for croation language: šđčćž) in my alaska
>>> xbase++ aplication.
>>> Still use version 1.90.355 SL1 with Hotfix Rollup 50.
>>> Has anybode same problem?
>>> Had you solved it?
>>> 
>>> Regards
>>> 
>>> Damir
>>> 
>> This can help also
>> Pozdrav
>> 
>> 
>> ---
>> Ta e-pošta je bila pregledana z Avast protivirusnim programom.
>> https://www.avast.com/antivirus
>
>Hi Miran!
>Your suggestion helped me.
>If I check "use legacy console" it works correctly again.
>Hope Microsoft (or Alaska) would correct it.
>Thank you 
>
>Pozdrav
>Damir


I used a /pm:pm switch while linking so it was in semi-graphic mode.

And comment by "Lasciate ogni speranza, voi che entrate qui" on MS or Alaska
fixing this. It is legacy stuff so noone will bother to fix it anyways.
Damir HodakRe: Windows 10 recent updates & international characters
on Thu, 01 Jun 2017 17:23:21 +0200
On Thu, 01 Jun 2017 11:29:46 +0200, Matej Jurac wrote:

> Damir Hodak wrote in message news:1ghf41emcbfxj.s5jsob46mdoe.dlg@40tude.net...
>>On Thu, 01 Jun 2017 09:58:03 +0200, Zupan Miran wrote:
>>
>>> Damir Hodak je 30.05. 2017 ob 14:44 napisal:
>>>> Hi everyone!
>>>> After installing recent updates for windows 10 I can't anymore type
>>>> international characters (for croation language: šđčćž) in my alaska
>>>> xbase++ aplication.
>>>> Still use version 1.90.355 SL1 with Hotfix Rollup 50.
>>>> Has anybode same problem?
>>>> Had you solved it?
>>>> 
>>>> Regards
>>>> 
>>>> Damir
>>>> 
>>> This can help also
>>> Pozdrav
>>> 
>>> 
>>> ---
>>> Ta e-pošta je bila pregledana z Avast protivirusnim programom.
>>> https://www.avast.com/antivirus
>>
>>Hi Miran!
>>Your suggestion helped me.
>>If I check "use legacy console" it works correctly again.
>>Hope Microsoft (or Alaska) would correct it.
>>Thank you 
>>
>>Pozdrav
>>Damir
> 
> 
> I used a /pm:pm switch while linking so it was in semi-graphic mode.
> 
> And comment by "Lasciate ogni speranza, voi che entrate qui" on MS or Alaska
> fixing this. It is legacy stuff so noone will bother to fix it anyways.

Yes, in semi-graphic mode (/pm:pm switch) works correctly, but in VIO mode
don't (unless you use legacy console).