Alaska Software Inc. - Newcomer - WAA-Problem
Alaska Software Inc. - Newcomer - WAA-Problem
Username: Password:
AuthorTopic: Newcomer - WAA-Problem
Wolfgang Newcomer - WAA-Problem
on Mon, 25 Jul 2005 14:46:44 +0200
Hi,
I'm new with xBase++.
I try sample Code ALASKA1.DLL. It works correct inclusive debugging.
But after rebuild the DLL WAA is unable to load ALASKA1.DLL !
I've nothing changed in source nor project files!
Any suggestions?????

My environment:
- WAA Version 1.80,
- Apache Webserver,
- Visual xBase++ 2.0.335 (pre release)
- xBase++ 1.82 (30day trial).
OS: Windows XP, service pack 2

Thanks for help.
Phil Ide
Re: Newcomer - WAA-Problem
on Mon, 25 Jul 2005 14:12:40 +0100
Wolfgang,

> Hi,
> I'm new with xBase++.
> I try sample Code ALASKA1.DLL. It works correct inclusive debugging.
> But after rebuild the DLL WAA is unable to load ALASKA1.DLL !
> I've nothing changed in source nor project files!
> Any suggestions?????
> 
> My environment:
> - WAA Version 1.80,
> - Apache Webserver,
> - Visual xBase++ 2.0.335 (pre release)
> - xBase++ 1.82 (30day trial).
> OS: Windows XP, service pack 2

You have a mismatch in versions.  If you are using Xbase++ v1.82, then you
also need WAA v1.82.

Regards,

Phil Ide

***************************************
* Xbase++ FAQ, Libraries and Sources: *
* goto: http://www.idep.org.uk/xbase  *
***************************************

Few women admit their age. Few men act theirs.
Wolfgang Re: Newcomer - WAA-Problem
on Mon, 25 Jul 2005 15:56:48 +0200
Phil Ide schrieb:
> Wolfgang,
> 
> 
>>Hi,
>>I'm new with xBase++.
>>I try sample Code ALASKA1.DLL. It works correct inclusive debugging.
>>But after rebuild the DLL WAA is unable to load ALASKA1.DLL !
>>I've nothing changed in source nor project files!
>>Any suggestions?????
>>
>>My environment:
>>- WAA Version 1.80,
>>- Apache Webserver,
>>- Visual xBase++ 2.0.335 (pre release)
>>- xBase++ 1.82 (30day trial).
>>OS: Windows XP, service pack 2
> 
> 
> You have a mismatch in versions.  If you are using Xbase++ v1.82, then you
> also need WAA v1.82.
> 
> Regards,

YES - easy solution
Thanks Phil
Shaun HerrickRe: Newcomer - WAA-Problem
on Fri, 07 Dec 2012 16:14:10 -0500
I have a similar issue with my WAA version must be updated to work with 
XB1.9
I receive the following error when attempting to run the server from the 
startwaa batch file:

"WAA1SRV.EXE - Entry Point Not Found
---------------------------
The procedure entry point __This_DLL_needs_version_1_82_0 could not be 
located in the dynamic link library XPPRT1.dll. "

on: http://www.alaska-software.com/products/waa/waa.shtm
attempted to download waa for xbp1.9 via Free Download 
[link]http://www.alaska-software.com/scripts/waa001.dll?WAA_PACKAGE=WebLib&WAA_FORM=ListFiles&WEBLIB_SECT=100[/link] 
, but get an error:
"WAA Gateway Error
Description:	WAA1GATE cannot establish connection to WAA1SRV
Code:	0
Message:	The operation completed successfully.
"

How can I obtain the correct version of WAA? I had downloaded the 
version I'm running from that link days earlier.

Thanks in advance,
Shaun

On 7/25/2005 9:12 AM, Phil Ide wrote:
> Wolfgang,
>
>> Hi,
>> I'm new with xBase++.
>> I try sample Code ALASKA1.DLL. It works correct inclusive debugging.
>> But after rebuild the DLL WAA is unable to load ALASKA1.DLL !
>> I've nothing changed in source nor project files!
>> Any suggestions?????
>>
>> My environment:
>> - WAA Version 1.80,
>> - Apache Webserver,
>> - Visual xBase++ 2.0.335 (pre release)
>> - xBase++ 1.82 (30day trial).
>> OS: Windows XP, service pack 2
>
> You have a mismatch in versions.  If you are using Xbase++ v1.82, then you
> also need WAA v1.82.
>
> Regards,
>
Thomas BraunRe: Newcomer - WAA-Problem
on Mon, 10 Dec 2012 10:30:01 +0100
Shaun Herrick wrote:

> How can I obtain the correct version of WAA? I had downloaded the 
> version I'm running from that link days earlier.

Contact Alaska Support via email.

Thomas