Alaska Software Inc. - DLL that must be updated with Xbase 2.0
Username: Password:
AuthorTopic: DLL that must be updated with Xbase 2.0
Osvaldo Luis AokiDLL that must be updated with Xbase 2.0
on Wed, 15 Mar 2017 22:11:23 +0100
Hi,

   Any people knows what DLL/LIB depende of XBASE compiler ?
   Because, we are migrating from 1.9 to 2.0 and is send message that some 
DLL is not in version 2.0.

   Some packets, I have doubts, like:
   - Xbzlib
   - Ot4xb
   - SQLXPP
   - XPPPDF

   Do you know if this DLL must to be compiled in xbase 2.0 ?

   Thanks
   Osvaldo L Aoki
Jonathan LeemingRe: DLL that must be updated with Xbase 2.0
on Wed, 15 Mar 2017 17:45:09 -0600
Hi,

Definitely XBPPDF51 which can be obtained from Edgar Borger...

edgar at borger.com.br 

Edgar's PDF library needs Ot4xb version 1.5.5.181 or higher which is a
free download from Pablo Botella... http://www.xbwin.com

I don't know about the other two.

Hope that helps... Jonathan

On Wed, 15 Mar 2017 22:11:23 +0100, Osvaldo Luis Aoki wrote:

>Hi,
>
>   Any people knows what DLL/LIB depende of XBASE compiler ?
>   Because, we are migrating from 1.9 to 2.0 and is send message that some 
>DLL is not in version 2.0.
>
>   Some packets, I have doubts, like:
>   - Xbzlib
>   - Ot4xb
>   - SQLXPP
>   - XPPPDF
>
>   Do you know if this DLL must to be compiled in xbase 2.0 ?
>
>   Thanks
>   Osvaldo L Aoki
Andreas Gehrs-Pahl
Re: DLL that must be updated with Xbase 2.0
on Thu, 16 Mar 2017 07:38:51 -0400
Osvaldo,

>Any people knows what DLL/LIB depende of XBASE compiler ?

All but OT4Xb are Xbase++ DLLs that need to be re-compiled with Xbase++ 2.0 
or their 2.0 versions must be used.

* The free XbZLib DLL(s) (and source code) for the latest version 2.03.183 
  can be downloaded from here:

	http://www.AbsoluteSoftwareLLC.com/Downloads/

Pre-compiled DLLs for Xbase++ 1.9 and 2.0 are included in the download.
The download also includes an older version of OT4Xb (Version 1.6.0.167).

* The free OT4Xb DLL(s) (and source code) can be downloaded from here:

	http://www.xbwin.com/

The latest version seems to be Version 1.6.4.5 and as those aren't Xbase++ 
DLLs, you can use them with any Xbase++ version.

* Boris provides compiled DLLs for SQLExpress (SQLXPP) for several Xbase++ 
  versions, which can be downloaded from here:

	http://www.xb2.net/Download.htm#SQLExpress

If your version is too old (the latest one is Version 3.3.0), you might need 
to pay for an upgrade to the current version, though.

* You can download XbpPDF from Edgar Borger's web site here:

	http://www.borger.com.br/softsupply/classes.html

The download also comes with DLLs for various Xbase++ versions. If you use 
an older version than 5.0, you may need to pay for an upgrade to the current 
version, though.

Hope that helps,

Andreas

Andreas Gehrs-Pahl
Absolute Software, LLC

phone: (989) 723-9927
email: Andreas@AbsoluteSoftwareLLC.com
web:   http://www.AbsoluteSoftwareLLC.com
[F]:   https://www.facebook.com/AbsoluteSoftwareLLC
Osvaldo Luis AokiRe: DLL that must be updated with Xbase 2.0
on Mon, 20 Mar 2017 02:53:10 +0100
HI,

   Thanks for all information.

   And about Fast Report FrSyst.DLL. Is it depends from Xbase Compiler too 
?
   If yes, where do I get this update ?

   Thanks,
   Osvaldo L Aoki

Andreas Gehrs-Pahl wrote in message 
news:q486lt8tqz6e.1tgij6p5bztgj.dlg@40tude.net...
>Osvaldo,
>
>>Any people knows what DLL/LIB depende of XBASE compiler ?
>
>All but OT4Xb are Xbase++ DLLs that need to be re-compiled with Xbase++ 
2.0 
>or their 2.0 versions must be used.
>
>* The free XbZLib DLL(s) (and source code) for the latest version 
2.03.183 
>  can be downloaded from here:
>
>	http://www.AbsoluteSoftwareLLC.com/Downloads/
>
>Pre-compiled DLLs for Xbase++ 1.9 and 2.0 are included in the download.
>The download also includes an older version of OT4Xb (Version 1.6.0.167).
>
>* The free OT4Xb DLL(s) (and source code) can be downloaded from here:
>
>	http://www.xbwin.com/
>
>The latest version seems to be Version 1.6.4.5 and as those aren't 
Xbase++ 
>DLLs, you can use them with any Xbase++ version.
>
>* Boris provides compiled DLLs for SQLExpress (SQLXPP) for several 
Xbase++ 
>  versions, which can be downloaded from here:
>
>	http://www.xb2.net/Download.htm#SQLExpress
>
>If your version is too old (the latest one is Version 3.3.0), you might 
need 
>to pay for an upgrade to the current version, though.
>
>* You can download XbpPDF from Edgar Borger's web site here:
>
>	http://www.borger.com.br/softsupply/classes.html
>
>The download also comes with DLLs for various Xbase++ versions. If you 
use 
>an older version than 5.0, you may need to pay for an upgrade to the 
current 
>version, though.
>
>Hope that helps,
>
>Andreas
Andreas Gehrs-Pahl
Re: DLL that must be updated with Xbase 2.0
on Thu, 23 Mar 2017 12:39:17 -0400
Osvaldo,

>Thanks for all information.

You are welcome.

>And about Fast Report FrSyst.DLL. Is it depends from Xbase Compiler too?
>If yes, where do I get this update ?

The FrSyst.DLL file is a FRAX (FastReport for Alaska XBase++) wrapper DLL 
for Fast Report 3 and was developed by Spirin Sergey (Paritet Soft). Since 
he died some years ago, there have been no updates or newer versions of the 
DLL (which was apparently developed in Delphi). As there seems to be no way 
to update FRAX, Alaska did some changes to Xbase++ 2.0 to allow the existing 
FrSyst.DLL to work with it. So you can (probably) use your existing DLL with 
Xbase++ 1.9 as well as 2.0.

Hope that helps,

Andreas

Andreas Gehrs-Pahl
Absolute Software, LLC

phone: (989) 723-9927
email: Andreas@AbsoluteSoftwareLLC.com
web:   http://www.AbsoluteSoftwareLLC.com
[F]:   https://www.facebook.com/AbsoluteSoftwareLLC
Frank GrossheinrichRe: DLL that must be updated with Xbase 2.0
on Fri, 24 Mar 2017 11:56:13 +0100
Hi Andreas,

sorry, can't resist  :

 > The FrSyst.DLL file is a FRAX (FastReport for Alaska XBase++) wrapper 
DLL

PROCEDURE Main
    LOCAL cProperProductName := Upper( "X" ) + Lower( "base++" )
    ? cProperProductName
RETURN( "Regards, Frank" )

On 23.03.2017 17:39, Andreas Gehrs-Pahl wrote:
> Osvaldo,
>
>> Thanks for all information.
>
> You are welcome.
>
>> And about Fast Report FrSyst.DLL. Is it depends from Xbase Compiler too?
>> If yes, where do I get this update ?
>
> The FrSyst.DLL file is a FRAX (FastReport for Alaska XBase++) wrapper DLL
> for Fast Report 3 and was developed by Spirin Sergey (Paritet Soft). Since
> he died some years ago, there have been no updates or newer versions of the
> DLL (which was apparently developed in Delphi). As there seems to be no way
> to update FRAX, Alaska did some changes to Xbase++ 2.0 to allow the existing
> FrSyst.DLL to work with it. So you can (probably) use your existing DLL with
> Xbase++ 1.9 as well as 2.0.
>
> Hope that helps,
>
> Andreas
>
Edgar Borger Re: DLL that must be updated with Xbase 2.0
on Thu, 16 Mar 2017 14:58:04 -0300
Hi Oswaldo,

you can get 2.0 dlls for XbpPDF from

V4 => http://www.borger.com.br/softsupply/pdf/xpppdf46.zip
V5 => http://www.borger.com.br/softsupply/pdf/xpppdf51.zip

Regards,
Edgar


Em 15/3/2017 18:11, Osvaldo Luis Aoki escreveu:
> Hi,
>
>    Any people knows what DLL/LIB depende of XBASE compiler ?
>    Because, we are migrating from 1.9 to 2.0 and is send message that some
> DLL is not in version 2.0.
>
>    Some packets, I have doubts, like:
>    - Xbzlib
>    - Ot4xb
>    - SQLXPP
>    - XPPPDF
>
>    Do you know if this DLL must to be compiled in xbase 2.0 ?
>
>    Thanks
>    Osvaldo L Aoki
>
Pablo Botella Re: DLL that must be updated with Xbase 2.0
on Sat, 18 Mar 2017 13:11:04 +0100
The Xbase++ 2.0 release from about december of last year was make the 
ot4xb function XbFpCall() to fail. Was fixed in ot4xb v 1.6.4.1 about 2 
months ago when a customer was notice it, so you just need to 
www.xbwin.com and download latest.

Was another issue with another release of Xbase++ 2.0 and FileTime64() 
class but ot4xb fixed in early 2015.

No other ot4xb and Xbase++ 2.0 issues reported

Regards,
Pablo Botella