MSComCtl2

MSComCtl2 Overview

Microsoft Windows Common Controls-2 6.0 (SP6)

Objects
DataObject
DataObjectFiles
Animation
UpDown
MonthView
DTPicker
FlatScrollBar

Constants
OLEDropConstants
DragOverConstants
ClipBoardConstants
OLEDropEffectConstants
ErrorConstants
AppearanceConstants
BorderStyleConstants
MousePointerConstants
OrientationConstants
BackStyleConstants
AlignmentConstants
DayConstants
MonthConstants
MonthViewHitTestAreas
FormatConstants
FlatScrollBarAppearanceConstants
ArrowsConstants


AlignmentConstants enumeration

Members

Constant | Value
cc2AlignmentLeft | 0
cc2AlignmentRight | 1


AppearanceConstants enumeration

Members

Constant | Value
cc2Flat | 0
cc23D | 1


ArrowsConstants enumeration

Members

Constant | Value
cc2Both | 0
cc2LeftUp | 1
cc2RightDown | 2


BackStyleConstants enumeration

Members

Constant | Value
cc2BackstyleTransparent | 0
cc2BackstyleOpaque | 1


BorderStyleConstants enumeration

Members

Constant | Value
cc2None | 0
cc2FixedSingle | 1


ClipBoardConstants enumeration

Members

Constant | Value
cc2CFText | 1
cc2CFBitmap | 2
cc2CFMetafile | 3
cc2CFDIB | 8
cc2CFPalette | 9
cc2CFEMetafile | 14
cc2CFFiles | 15
cc2CFRTF | -16639


DayConstants enumeration

Members

Constant | Value
mvwSunday | 1
mvwMonday | 2
mvwTuesday | 3
mvwWednesday | 4
mvwThursday | 5
mvwFriday | 6
mvwSaturday | 7


DragOverConstants enumeration

Members

Constant | Value
cc2Enter | 0
cc2Leave | 1
cc2Over | 2


ErrorConstants enumeration

Members

Constant | Value
cc2BadFileNameOrNumber | 52
cc2FileNotFound | 53
cc2InvalidPropertyValue | 380
cc2SetNotSupportedAtRuntime | 382
cc2SetNotSupported | 383
cc2GetNotSupported | 394
cc2DataObjectLocked | 672
cc2ExpectedAnArgument | 673
cc2InvalidProcedureCall | 5
cc2InvalidObjectUse | 425
cc2WrongClipboardFormat | 461
cc2RecursiveOleDrag | 674
cc2FormatNotByteArray | 675
cc2DataNotSetForFormat | 676
cc2InconsistentObject | 35750
cc2ErrorDuringSet | 35751
cc2ErrorOpeningVideo | 35752
cc2ErrorPlayingVideo | 35753
cc2VideoNotOpen | 35755
cc2ErrorStoppingVideo | 35757
cc2ErrorClosingVideo | 35758
cc2CantStopAutoPlay | 35759
cc2NoValidBuddyCtl | 35754
cc2AutoBuddyNotSet | 35756
cc2BuddyNotASibling | 35760
cc2NoUpDownAsBuddy | 35761
cc2InvalidRange | 35770
cc2InvalidMaxDate | 35771
cc2InvalidMinDate | 35772
cc2DateOutOfRange | 35773
cc2InvalidMaxDateMin | 35774
cc2InvalidMinDateMax | 35775
cc2InvalidRowColValue | 35776
cc2InvalidRowColTotal | 35777
cc2MonthViewError | 35778
cc2SetDayMultiSelectOn | 35779
cc2SetDayOfWeekMultiSelectOn | 35780
cc2SetMonthMultiSelectOn | 35781
cc2SetWeekMultiSelectOn | 35782
cc2SetYearMultiSelectOn | 35783
cc2SetMaxSelCountMultiSelectOff | 35784
cc2SetSelEndMultiSelectOff | 35785
cc2SetSelStartMultiSelectOff | 35786
cc2NullValueNotAllowed | 35787
cc2DTPickerError | 35788
cc2ScrollValueOutOfRange | 35789


FlatScrollBarAppearanceConstants enumeration

Members

Constant | Value
fsb3D | 0
fsbFlat | 1
fsbTrack3D | 2


FormatConstants enumeration

Members

Constant | Value
dtpLongDate | 0
dtpShortDate | 1
dtpTime | 2
dtpCustom | 3


MonthConstants enumeration

Members

Constant | Value
mvwJanuary | 1
mvwFebruary | 2
mvwMarch | 3
mvwApril | 4
mvwMay | 5
mvwJune | 6
mvwJuly | 7
mvwAugust | 8
mvwSeptember | 9
mvwOctober | 10
mvwNovember | 11
mvwDecember | 12


MonthViewHitTestAreas enumeration

Members

Constant | Value
mvwCalendarBack | 0
mvwCalendarDate | 1
mvwCalendarDateNext | 2
mvwCalendarDatePrev | 3
mvwCalendarDay | 4
mvwCalendarWeekNum | 5
mvwNoWhere | 6
mvwTitleBack | 7
mvwTitleBtnNext | 8
mvwTitleBtnPrev | 9
mvwTitleMonth | 10
mvwTitleYear | 11
mvwTodayLink | 12


MousePointerConstants enumeration

Members

Constant | Value
cc2Default | 0
cc2Arrow | 1
cc2Cross | 2
cc2IBeam | 3
cc2Icon | 4
cc2Size | 5
cc2SizeNESW | 6
cc2SizeNS | 7
cc2SizeNWSE | 8
cc2SizeEW | 9
cc2UpArrow | 10
cc2Hourglass | 11
cc2NoDrop | 12
cc2ArrowHourglass | 13
cc2ArrowQuestion | 14
cc2SizeAll | 15
cc2Custom | 99


OLEDropConstants enumeration

Members

Constant | Value
cc2OLEDropNone | 0
cc2OLEDropManual | 1


OLEDropEffectConstants enumeration

Members

Constant | Value
cc2OLEDropEffectNone | 0
cc2OLEDropEffectCopy | 1
cc2OLEDropEffectMove | 2
cc2OLEDropEffectScroll | -2147483648


OrientationConstants enumeration

Members

Constant | Value
cc2OrientationVertical | 0
cc2OrientationHorizontal | 1


Animation

Animation object

Animation Control


Click event

A mouse button has been clicked on the Animation control

Syntax

Sub object_Click

The Click event syntax has these named arguments:

Part Description


DblClick event

A mouse button has been double-clicked on the Animation control

Syntax

Sub object_DblClick

The DblClick event syntax has these named arguments:

Part Description


MouseDown event

A mouse button was pressed over the Animation control

Syntax

Sub object_MouseDown(Button As Integer, Shift As Integer, x As Single, y As Single)

The MouseDown event syntax has these named arguments:

Part | Description
Button | Integer
Shift | Integer
x | Single
y | Single


MouseMove event

The mouse has moved over the Animation control

Syntax

Sub object_MouseMove(Button As Integer, Shift As Integer, x As Single, y As Single)

The MouseMove event syntax has these named arguments:

Part | Description
Button | Integer
Shift | Integer
x | Single
y | Single


MouseUp event

A mouse button was released from the Animation control

Syntax

Sub object_MouseUp(Button As Integer, Shift As Integer, x As Single, y As Single)

The MouseUp event syntax has these named arguments:

Part | Description
Button | Integer
Shift | Integer
x | Single
y | Single


OLECompleteDrag event

OLECompleteDrag event

Syntax

Sub object_OLECompleteDrag(Effect As Long)

The OLECompleteDrag event syntax has these named arguments:

Part | Description
Effect | Long


OLEDragDrop event

OLEDragDrop event

Syntax

Sub object_OLEDragDrop(Data As DataObject, Effect As Long, Button As Integer, Shift As Integer, x As float, y As float)

The OLEDragDrop event syntax has these named arguments:

Part | Description
Data | DataObject
Effect | Long
Button | Integer
Shift | Integer
x | float
y | float


OLEDragOver event

OLEDragOver event

Syntax

Sub object_OLEDragOver(Data As DataObject, Effect As Long, Button As Integer, Shift As Integer, x As float, y As float, State As Integer)

The OLEDragOver event syntax has these named arguments:

Part | Description
Data | DataObject
Effect | Long
Button | Integer
Shift | Integer
x | float
y | float
State | Integer


OLEGiveFeedback event

OLEGiveFeedback event

Syntax

Sub object_OLEGiveFeedback(Effect As Long, DefaultCursors As Boolean)

The OLEGiveFeedback event syntax has these named arguments:

Part | Description
Effect | Long
DefaultCursors | Boolean


OLESetData event

OLESetData event

Syntax

Sub object_OLESetData(Data As DataObject, DataFormat As Integer)

The OLESetData event syntax has these named arguments:

Part | Description
Data | DataObject
DataFormat | Integer


OLEStartDrag event

OLEStartDrag event

Syntax

Sub object_OLEStartDrag(Data As DataObject, AllowedEffects As Long)

The OLEStartDrag event syntax has these named arguments:

Part | Description
Data | DataObject
AllowedEffects | Long


AboutBox method

Return Type

A Boolean value.

Syntax

object.AboutBox

The AboutBox method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.


Close method

Method to close the currently open AVI file

Return Type

A Boolean value.

Syntax

object.Close

The Close method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.


OLEDrag method

Starts an OLE drag/drop event with the given control as the source.

Return Type

A Boolean value.

Syntax

object.OLEDrag

The OLEDrag method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.


Open method

Method to open an existing AVI file

Return Type

A Boolean value.

Syntax

object.Open(bstrFilename As String)

The Open method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.
bstrFilename | String


Play method

Method to play the currently open AVI file

Return Type

A Boolean value.

Syntax

object.Play(varRepeatCount As Variant, varStartFrame As Variant, varEndFrame As Variant)

The Play method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.
varRepeatCount | Variant
varStartFrame | Variant
varEndFrame | Variant


Stop method

Method to stop playing the current AVI file

Return Type

A Boolean value.

Syntax

object.Stop

The Stop method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.


AutoPlay property (Animation)

Get/Set the AutoPlay property

Property type

A No Return Value value.

Syntax

object.AutoPlay(rhs As Boolean) [= value]

The AutoPlay property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.
value | A No Return Value value.


BackColor property (Animation)

Returns/sets the background color used for transparent animations.

Property type

A No Return Value value.

Syntax

object.BackColor(rhs As OLE_COLOR) [= value]

The BackColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.
value | A No Return Value value.


BackStyle property (Animation)

Get/Set the background style

Property type

A No Return Value value.

Syntax

object.BackStyle(rhs As BackStyleConstants) [= value]

The BackStyle property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.
value | A No Return Value value.


Center property (Animation)

Get/Set the center property

Property type

A No Return Value value.

Syntax

object.Center(rhs As Boolean) [= value]

The Center property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.
value | A No Return Value value.


Enabled property (Animation)

Returns/sets a value that determines whether a form or control can respond to user-generated events.

Property type

A No Return Value value.

Syntax

object.Enabled(rhs As Boolean) [= value]

The Enabled property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.
value | A No Return Value value.


hWnd property (Animation)

Returns a handle to a form or control.

Property type

A OLE_HANDLE value.

Syntax

object.hWnd [= value]

The hWnd property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.
value | A OLE_HANDLE value.


OLEDropMode property (Animation)

Returns/Sets whether this control can act as an OLE drop target.

Property type

A OLEDropConstants value.

Syntax

object.OLEDropMode [= value]

The OLEDropMode property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Animation.
value | A OLEDropConstants value.


DataObject

DataObject object


Clear method

Clears all data and formats in a DataObject object.

Return Type

A Boolean value.

Syntax

object.Clear

The Clear method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DataObject.


GetData method

Retrieves data of a specified format from a DataObject object.

Return Type

A Variant value.

Return Type

A Boolean value.

Syntax

object.GetData(sFormat As Integer)

The GetData method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DataObject.
sFormat | Integer


GetFormat method

Determines if a specified clipboard format is supported by the DataObject object.

Return Type

A Boolean value.

Return Type

A Boolean value.

Syntax

object.GetFormat(sFormat As Integer)

The GetFormat method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DataObject.
sFormat | Integer


SetData method

Adds a supported format and possibly its data to a DataObject object.

Return Type

A Boolean value.

Syntax

object.SetData(vValue As Variant, vFormat As Variant)

The SetData method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DataObject.
vValue | Variant
vFormat | Variant


Files property (DataObject)

A collection of filenames used by the vbCFFiles format.

Property type

A IVBDataObjectFiles value.

Syntax

object.Files [= value]

The Files property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DataObject.
value | A IVBDataObjectFiles value.


DataObjectFiles

DataObjectFiles object


_NewEnum method

Return Type

A IUnknown value.

Return Type

A Boolean value.

Syntax

object._NewEnum

The _NewEnum method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DataObjectFiles.


Add method

Adds a filename to the Files collection of a DataObject object (vbCFFiles format only).

Return Type

A Boolean value.

Syntax

object.Add(bstrFilename As String, vIndex As Variant)

The Add method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DataObjectFiles.
bstrFilename | String
vIndex | Variant


Clear method

Clears all filenames stored in the Files collection of a DataObject object (vbCFFiles format only).

Return Type

A Boolean value.

Syntax

object.Clear

The Clear method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DataObjectFiles.


Remove method

Removes a filename from the Files collection of a DataObject object (vbCFFiles format only).

Return Type

A Boolean value.

Syntax

object.Remove(vIndex As Variant)

The Remove method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DataObjectFiles.
vIndex | Variant


Count property (DataObjectFiles)

Returns the number of filenames in the Files collection of a DataObject object (vbCFFiles format only).

Property type

A Long value.

Syntax

object.Count [= value]

The Count property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DataObjectFiles.
value | A Long value.


Item property (DataObjectFiles)

Returns a specific filename by index from the Files collection of a DataObject object (vbCFFiles format only).

Property type

A String value.

Syntax

object.Item(lIndex As Long) [= value]

The Item property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DataObjectFiles.
value | A String value.


DTPicker

DTPicker object

Microsoft Date and Time Picker Control


CallbackKeyDown event

Occurs when the user presses a key when the insertion point is over a callback field.

Syntax

Sub object_CallbackKeyDown(KeyCode As Integer, Shift As Integer, CallbackField As String, CallbackDate As Date)

The CallbackKeyDown event syntax has these named arguments:

Part | Description
KeyCode | Integer
Shift | Integer
CallbackField | String
CallbackDate | Date


Change event

Occurs when the user selects a new date or changes a date in the edit portion of the control.

Syntax

Sub object_Change

The Change event syntax has these named arguments:

Part Description


Click event

Occurs when the user presses and then releases a mouse button over an object.

Syntax

Sub object_Click

The Click event syntax has these named arguments:

Part Description


CloseUp event

Occurs when the user is finished selecting a date from the dropdown calendar.

Syntax

Sub object_CloseUp

The CloseUp event syntax has these named arguments:

Part Description


DblClick event

Occurs when you press and release a mouse button and then press and release it again over an object.

Syntax

Sub object_DblClick

The DblClick event syntax has these named arguments:

Part Description


DropDown event

Occurs when the dropdown calendar is about to drop down.

Syntax

Sub object_DropDown

The DropDown event syntax has these named arguments:

Part Description


Format property (DTPicker)

Determines whether dates and times are displayed using standard or custom formatting.

Property type

A FormatConstants value.

Syntax

object.Format [= value]

The Format property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A FormatConstants value.


FormatSize event

Occurs when the control needs to know the maximum allowable size of a callback field.

Syntax

Sub object_FormatSize(CallbackField As String, Size As Integer)

The FormatSize event syntax has these named arguments:

Part | Description
CallbackField | String
Size | Integer


KeyDown event

Occurs when the user presses a key while an object has the focus.

Syntax

Sub object_KeyDown(KeyCode As Integer, Shift As Integer)

The KeyDown event syntax has these named arguments:

Part | Description
KeyCode | Integer
Shift | Integer


KeyPress event

Occurs when the user presses and releases an ANSI key.

Syntax

Sub object_KeyPress(KeyAscii As Integer)

The KeyPress event syntax has these named arguments:

Part | Description
KeyAscii | Integer


KeyUp event

Occurs when the user releases a key while an object has the focus.

Syntax

Sub object_KeyUp(KeyCode As Integer, Shift As Integer)

The KeyUp event syntax has these named arguments:

Part | Description
KeyCode | Integer
Shift | Integer


MouseDown event

Occurs when the user presses the mouse button while the mousepointer is over an object.

Syntax

Sub object_MouseDown(Button As Integer, Shift As Integer, x As Single, y As Single)

The MouseDown event syntax has these named arguments:

Part | Description
Button | Integer
Shift | Integer
x | Single
y | Single


MouseMove event

Occurs when the user moves the mousepointer over an object.

Syntax

Sub object_MouseMove(Button As Integer, Shift As Integer, x As Single, y As Single)

The MouseMove event syntax has these named arguments:

Part | Description
Button | Integer
Shift | Integer
x | Single
y | Single


MouseUp event

Occurs when the user releases the mouse button while the mousepointer is over an object.

Syntax

Sub object_MouseUp(Button As Integer, Shift As Integer, x As Single, y As Single)

The MouseUp event syntax has these named arguments:

Part | Description
Button | Integer
Shift | Integer
x | Single
y | Single


AboutBox method

Return Type

A Boolean value.

Syntax

object.AboutBox

The AboutBox method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.


OLEDrag method

Starts an OLE drag/drop event with the given control as the source.

Return Type

A Boolean value.

Syntax

object.OLEDrag

The OLEDrag method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.


Refresh method

Forces a complete repaint of a form or control.

Return Type

A Boolean value.

Syntax

object.Refresh

The Refresh method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.


_Value property (DTPicker)

Property type

A Variant value.

Syntax

object._Value [= value]

The _Value property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Variant value.


CalendarBackColor property (DTPicker)

Returns/sets the background color used to display the month portion of the dropdown calendar.

Property type

A OLE_COLOR value.

Syntax

object.CalendarBackColor [= value]

The CalendarBackColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A OLE_COLOR value.


CalendarForeColor property (DTPicker)

Returns/sets the foreground color used to display text in the month portion of the dropdown calendar.

Property type

A OLE_COLOR value.

Syntax

object.CalendarForeColor [= value]

The CalendarForeColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A OLE_COLOR value.


CalendarTitleBackColor property (DTPicker)

Returns/sets the background color used to display the title portion of the dropdown calendar.

Property type

A OLE_COLOR value.

Syntax

object.CalendarTitleBackColor [= value]

The CalendarTitleBackColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A OLE_COLOR value.


CalendarTitleForeColor property (DTPicker)

Returns/sets the foreground color used to display the title portion of the dropdown calendar.

Property type

A OLE_COLOR value.

Syntax

object.CalendarTitleForeColor [= value]

The CalendarTitleForeColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A OLE_COLOR value.


CalendarTrailingForeColor property (DTPicker)

Returns/sets the foreground color used to display the days at the beginning and end of the dropdown calendar that are from previous and following months.

Property type

A OLE_COLOR value.

Syntax

object.CalendarTrailingForeColor [= value]

The CalendarTrailingForeColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A OLE_COLOR value.


CheckBox property (DTPicker)

Returns/sets whether the control displays a checkbox to the left of the date. When unchecked, no date is selected.

Property type

A Boolean value.

Syntax

object.CheckBox [= value]

The CheckBox property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Boolean value.


CustomFormat property (DTPicker)

Returns/sets the custom format string used to format the date and/or time displayed in the control.

Property type

A String value.

Syntax

object.CustomFormat [= value]

The CustomFormat property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A String value.


Day property (DTPicker)

Returns/sets the day number [1-31] for the current date.

Property type

A Variant value.

Syntax

object.Day [= value]

The Day property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Variant value.


DayOfWeek property (DTPicker)

Returns the day of the week [0-6] for the current date.

Property type

A Variant value.

Syntax

object.DayOfWeek [= value]

The DayOfWeek property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Variant value.


Enabled property (DTPicker)

Returns/sets a value that determines whether a form or control can respond to user-generated events.

Property type

A Boolean value.

Syntax

object.Enabled [= value]

The Enabled property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Boolean value.


Font property (DTPicker)

Returns a Font object.

Property type

A IFontDisp value.

Syntax

object.Font [= value]

The Font property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A IFontDisp value.


Hour property (DTPicker)

Returns/sets the hour number [0-23] for the current time.

Property type

A Variant value.

Syntax

object.Hour [= value]

The Hour property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Variant value.


hWnd property (DTPicker)

Returns a handle to a form or control.

Property type

A OLE_HANDLE value.

Syntax

object.hWnd [= value]

The hWnd property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A OLE_HANDLE value.


MaxDate property (DTPicker)

Returns/sets the latest date that can be displayed or accepted by the control.

Property type

A Date value.

Syntax

object.MaxDate [= value]

The MaxDate property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Date value.


MinDate property (DTPicker)

Returns/sets the earliest date that can be displayed or accepted by the control.

Property type

A Date value.

Syntax

object.MinDate [= value]

The MinDate property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Date value.


Minute property (DTPicker)

Returns/sets the minute number [0-59] for the current time.

Property type

A Variant value.

Syntax

object.Minute [= value]

The Minute property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Variant value.


Month property (DTPicker)

Returns/sets the month number [1-12] for the current date.

Property type

A Variant value.

Syntax

object.Month [= value]

The Month property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Variant value.


MouseIcon property (DTPicker)

Sets a custom mouse icon.

Property type

A IPictureDisp value.

Syntax

object.MouseIcon [= value]

The MouseIcon property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A IPictureDisp value.


MousePointer property (DTPicker)

Returns/sets the type of mouse pointer displayed when over part of an object.

Property type

A MousePointerConstants value.

Syntax

object.MousePointer [= value]

The MousePointer property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A MousePointerConstants value.


OLEDropMode property (DTPicker)

Returns/Sets whether this control can act as an OLE drop target.

Property type

A OLEDropConstants value.

Syntax

object.OLEDropMode [= value]

The OLEDropMode property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A OLEDropConstants value.


Second property (DTPicker)

Returns/sets the second number [0-59] for the current time.

Property type

A Variant value.

Syntax

object.Second [= value]

The Second property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Variant value.


UpDown property (DTPicker)

Returns/sets a value that determines whether an updown (spin) button is used to modify dates instead of a dropdown calendar.

Property type

A Boolean value.

Syntax

object.UpDown [= value]

The UpDown property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Boolean value.


Value property (DTPicker)

Returns/sets the current date.

Property type

A Variant value.

Syntax

object.Value [= value]

The Value property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Variant value.


Year property (DTPicker)

Returns/sets the year for the current date.

Property type

A Variant value.

Syntax

object.Year [= value]

The Year property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type DTPicker.
value | A Variant value.


FlatScrollBar

FlatScrollBar object

Microsoft Flat Scrollbar Control


Change event

Occurs when the user causes the Value property of the scroll bar to change.

Syntax

Sub object_Change

The Change event syntax has these named arguments:

Part Description


Scroll event

Occurs when the scroll box is being dragged by the user.

Syntax

Sub object_Scroll

The Scroll event syntax has these named arguments:

Part Description


AboutBox method

Return Type

A Boolean value.

Syntax

object.AboutBox

The AboutBox method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.


Refresh method

Forces a complete repaint of a form or control.

Return Type

A Boolean value.

Syntax

object.Refresh

The Refresh method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.


_Value property (FlatScrollBar)

Property type

A Integer value.

Syntax

object._Value [= value]

The _Value property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A Integer value.


Appearance property (FlatScrollBar)

Returns/sets whether or not controls, Forms or an MDIForm are painted at run time with 3-D effects.

Property type

A FlatScrollBarAppearanceConstants value.

Syntax

object.Appearance [= value]

The Appearance property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A FlatScrollBarAppearanceConstants value.


Arrows property (FlatScrollBar)

Returns/sets which direction buttons will be enabled.

Property type

A ArrowsConstants value.

Syntax

object.Arrows [= value]

The Arrows property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A ArrowsConstants value.


Enabled property (FlatScrollBar)

Returns/sets a value that determines whether a form or control can respond to user-generated events.

Property type

A Boolean value.

Syntax

object.Enabled [= value]

The Enabled property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A Boolean value.


hWnd property (FlatScrollBar)

Returns a handle to a form or control.

Property type

A OLE_HANDLE value.

Syntax

object.hWnd [= value]

The hWnd property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A OLE_HANDLE value.


LargeChange property (FlatScrollBar)

Returns/sets a value that determines the amount of change to the Value property when the user clicks the area between the scroll box and the scroll arrow.

Property type

A Integer value.

Syntax

object.LargeChange [= value]

The LargeChange property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A Integer value.


Max property (FlatScrollBar)

Returns/sets the scrollbar's maximum Value property setting.

Property type

A Integer value.

Syntax

object.Max [= value]

The Max property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A Integer value.


Min property (FlatScrollBar)

Returns/sets the scrollbar's minimum Value property setting.

Property type

A Integer value.

Syntax

object.Min [= value]

The Min property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A Integer value.


MouseIcon property (FlatScrollBar)

Sets a custom mouse icon.

Property type

A IPictureDisp value.

Syntax

object.MouseIcon [= value]

The MouseIcon property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A IPictureDisp value.


MousePointer property (FlatScrollBar)

Returns/sets the type of mouse pointer displayed when over part of an object.

Property type

A MousePointerConstants value.

Syntax

object.MousePointer [= value]

The MousePointer property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A MousePointerConstants value.


Orientation property (FlatScrollBar)

Returns/sets a value that determines whether the scrollbar is vertical or horizontal.

Property type

A OrientationConstants value.

Syntax

object.Orientation [= value]

The Orientation property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A OrientationConstants value.


SmallChange property (FlatScrollBar)

Returns/sets a value that determines the amount of change to the Value property when the user clicks a scroll arrow.

Property type

A Integer value.

Syntax

object.SmallChange [= value]

The SmallChange property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A Integer value.


Value property (FlatScrollBar)

Returns/sets the current position of the scroll bar.

Property type

A Integer value.

Syntax

object.Value [= value]

The Value property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FlatScrollBar.
value | A Integer value.


MonthView

MonthView object

Microsoft MonthView Control


DateClick event

Occurs when the user presses and then releases a mouse button over a valid date.

Syntax

Sub object_DateClick(DateClicked As Date)

The DateClick event syntax has these named arguments:

Part | Description
DateClicked | Date


DateDblClick event

Occurs when the user presses and then releases a mouse button and then presses and releases it again over a valid date.

Syntax

Sub object_DateDblClick(DateDblClicked As Date)

The DateDblClick event syntax has these named arguments:

Part | Description
DateDblClicked | Date


GetDayBold event

Occurs when the control is about to display a new range of dates and needs to know which dates should be displayed with a bold font.

Syntax

Sub object_GetDayBold(StartDate As Date, Count As Integer, State As unknown - type)

The GetDayBold event syntax has these named arguments:

Part | Description
StartDate | Date
Count | Integer
State | unknown - type


SelChange event

Occurs when the user selects a new date or range of dates.

Syntax

Sub object_SelChange(StartDate As Date, EndDate As Date, Cancel As Boolean)

The SelChange event syntax has these named arguments:

Part | Description
StartDate | Date
EndDate | Date
Cancel | Boolean


AboutBox method

Return Type

A Boolean value.

Syntax

object.AboutBox

The AboutBox method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.


ComputeControlSize method

A method that returns the width and height of a MonthView control for a given number of rows and columns.

Return Type

A Boolean value.

Syntax

object.ComputeControlSize(Rows As Integer, Columns As Integer, Width As float, Height As float)

The ComputeControlSize method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
Rows | Integer
Columns | Integer
Width | float
Height | float


HitTest method

A method that returns a value which indicates the MonthView element located at the specified x,y coordinates.

Return Type

A MonthViewHitTestAreas value.

Return Type

A Boolean value.

Syntax

object.HitTest(x As Long, y As Long, Date As Date)

The HitTest method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
x | Long
y | Long
Date | Date


OLEDrag method

Starts an OLE drag/drop event with the given control as the source.

Return Type

A Boolean value.

Syntax

object.OLEDrag

The OLEDrag method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.


Refresh method

Forces a complete repaint of a form or control.

Return Type

A Boolean value.

Syntax

object.Refresh

The Refresh method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.


_Value property (MonthView)

Property type

A Date value.

Syntax

object._Value [= value]

The _Value property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Date value.


Appearance property (MonthView)

Returns/sets whether or not controls, Forms or an MDIForm are painted at run time with 3-D effects.

Property type

A AppearanceConstants value.

Syntax

object.Appearance [= value]

The Appearance property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A AppearanceConstants value.


BackColor property (MonthView)

Returns/sets the background color used to display text and graphics in an object.

Property type

A OLE_COLOR value.

Syntax

object.BackColor [= value]

The BackColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A OLE_COLOR value.


BorderStyle property (MonthView)

Returns/sets the border style for an object.

Property type

A BorderStyleConstants value.

Syntax

object.BorderStyle [= value]

The BorderStyle property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A BorderStyleConstants value.


Day property (MonthView)

Returns/sets the day number [1-31] for the currently selected date.

Property type

A Integer value.

Syntax

object.Day [= value]

The Day property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Integer value.


DayBold property (MonthView)

An array of boolean values, 1 for each Visible Day, indicating whether the day is displayed using a bold font. Indexed by date.

Property type

A Boolean value.

Syntax

object.DayBold(dateIndex As Date) [= value]

The DayBold property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Boolean value.


DayOfWeek property (MonthView)

Returns the day of the week [0-6] for the currently selected date.

Property type

A DayConstants value.

Syntax

object.DayOfWeek [= value]

The DayOfWeek property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A DayConstants value.


Enabled property (MonthView)

Returns/sets a value that determines whether a form or control can respond to user-generated events.

Property type

A Boolean value.

Syntax

object.Enabled [= value]

The Enabled property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Boolean value.


Font property (MonthView)

Returns a Font object.

Property type

A IFontDisp value.

Syntax

object.Font [= value]

The Font property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A IFontDisp value.


ForeColor property (MonthView)

Returns/sets the foreground color used to display text and graphics in an object.

Property type

A OLE_COLOR value.

Syntax

object.ForeColor [= value]

The ForeColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A OLE_COLOR value.


hWnd property (MonthView)

Returns a handle to a form or control.

Property type

A OLE_HANDLE value.

Syntax

object.hWnd [= value]

The hWnd property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A OLE_HANDLE value.


MaxDate property (MonthView)

Returns/sets the latest date that can be displayed or accepted by the control.

Property type

A Date value.

Syntax

object.MaxDate [= value]

The MaxDate property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Date value.


MaxSelCount property (MonthView)

Returns/sets the limit on the number of dates that a user can multi-select.

Property type

A Integer value.

Syntax

object.MaxSelCount [= value]

The MaxSelCount property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Integer value.


MinDate property (MonthView)

Returns/sets the earliest date that can be displayed or accepted by the control.

Property type

A Date value.

Syntax

object.MinDate [= value]

The MinDate property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Date value.


Month property (MonthView)

Returns/sets the month number [1-12] for the currently selected date.

Property type

A MonthConstants value.

Syntax

object.Month [= value]

The Month property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A MonthConstants value.


MonthBackColor property (MonthView)

Returns/sets the background color used to display the month portion of the MonthView.

Property type

A OLE_COLOR value.

Syntax

object.MonthBackColor [= value]

The MonthBackColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A OLE_COLOR value.


MonthColumns property (MonthView)

Returns/sets the number of months displayed horizontally across the control.

Property type

A Integer value.

Syntax

object.MonthColumns [= value]

The MonthColumns property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Integer value.


MonthRows property (MonthView)

Returns/sets the number of months displayed vertically in the control.

Property type

A Integer value.

Syntax

object.MonthRows [= value]

The MonthRows property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Integer value.


MouseIcon property (MonthView)

Sets a custom mouse icon.

Property type

A IPictureDisp value.

Syntax

object.MouseIcon [= value]

The MouseIcon property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A IPictureDisp value.


MousePointer property (MonthView)

Returns/sets the type of mouse pointer displayed when over part of an object.

Property type

A MousePointerConstants value.

Syntax

object.MousePointer [= value]

The MousePointer property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A MousePointerConstants value.


MultiSelect property (MonthView)

Returns/sets a value that determines whether the user can select multiple dates.

Property type

A Boolean value.

Syntax

object.MultiSelect [= value]

The MultiSelect property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Boolean value.


OLEDropMode property (MonthView)

Returns/Sets whether this control can act as an OLE drop target.

Property type

A OLEDropConstants value.

Syntax

object.OLEDropMode [= value]

The OLEDropMode property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A OLEDropConstants value.


ScrollRate property (MonthView)

Returns/sets a value that determines the number of months that the control moves when the user clicks a scroll button.

Property type

A Integer value.

Syntax

object.ScrollRate [= value]

The ScrollRate property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Integer value.


SelEnd property (MonthView)

Returns/sets the end date for the current selection range.

Property type

A Date value.

Syntax

object.SelEnd [= value]

The SelEnd property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Date value.


SelStart property (MonthView)

Returns/sets the start date for the current selection range.

Property type

A Date value.

Syntax

object.SelStart [= value]

The SelStart property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Date value.


ShowToday property (MonthView)

Returns/sets a value that determines whether the control displays the 'Today xx/xx/xx' literal at the bottom of the MonthView.

Property type

A Boolean value.

Syntax

object.ShowToday [= value]

The ShowToday property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Boolean value.


ShowWeekNumbers property (MonthView)

Returns/sets a value that determines whether the control displays week numbers to the left of each row of days.

Property type

A Boolean value.

Syntax

object.ShowWeekNumbers [= value]

The ShowWeekNumbers property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Boolean value.


StartOfWeek property (MonthView)

Returns/sets a value that determines the day of the week [Mon-Sun] displayed in the leftmost column of days.

Property type

A DayConstants value.

Syntax

object.StartOfWeek [= value]

The StartOfWeek property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A DayConstants value.


TitleBackColor property (MonthView)

Returns/sets the background color used to display the title portion of the MonthView.

Property type

A OLE_COLOR value.

Syntax

object.TitleBackColor [= value]

The TitleBackColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A OLE_COLOR value.


TitleForeColor property (MonthView)

Returns/sets the foreground color used to display the title portion of the MonthView.

Property type

A OLE_COLOR value.

Syntax

object.TitleForeColor [= value]

The TitleForeColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A OLE_COLOR value.


TrailingForeColor property (MonthView)

Returns/sets the foreground color used to display the days at the beginning and end of the MonthView that are from previous and following months.

Property type

A OLE_COLOR value.

Syntax

object.TrailingForeColor [= value]

The TrailingForeColor property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A OLE_COLOR value.


Value property (MonthView)

Returns/sets the currently selected date.

Property type

A Date value.

Syntax

object.Value [= value]

The Value property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Date value.


VisibleDays property (MonthView)

An array of dates, 1 for each day currently displayed. Indexed by a number from 1 to number of days currently displayed.

Property type

A Date value.

Syntax

object.VisibleDays(sIndex As Integer) [= value]

The VisibleDays property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Date value.


Week property (MonthView)

Returns/sets the week number [1-52] for the currently selected date.

Property type

A Integer value.

Syntax

object.Week [= value]

The Week property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Integer value.


Year property (MonthView)

Returns/sets the year for the currently selected date.

Property type

A Integer value.

Syntax

object.Year [= value]

The Year property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type MonthView.
value | A Integer value.


UpDown

UpDown object

UpDown Control


Change event

The current position has changed

Syntax

Sub object_Change

The Change event syntax has these named arguments:

Part Description


DownClick event

The down button on the UpDown control has been clicked

Syntax

Sub object_DownClick

The DownClick event syntax has these named arguments:

Part Description


MouseDown event

A mouse button was pressed over the UpDown control

Syntax

Sub object_MouseDown(Button As Integer, Shift As Integer, x As Single, y As Single)

The MouseDown event syntax has these named arguments:

Part | Description
Button | Integer
Shift | Integer
x | Single
y | Single


MouseMove event

The mouse has moved over the UpDown control

Syntax

Sub object_MouseMove(Button As Integer, Shift As Integer, x As Single, y As Single)

The MouseMove event syntax has these named arguments:

Part | Description
Button | Integer
Shift | Integer
x | Single
y | Single


MouseUp event

A mouse button was released from the UpDown control

Syntax

Sub object_MouseUp(Button As Integer, Shift As Integer, x As Single, y As Single)

The MouseUp event syntax has these named arguments:

Part | Description
Button | Integer
Shift | Integer
x | Single
y | Single


UpClick event

The up button on the UpDown control has been clicked

Syntax

Sub object_UpClick

The UpClick event syntax has these named arguments:

Part Description


AboutBox method

Return Type

A Boolean value.

Syntax

object.AboutBox

The AboutBox method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.


OLEDrag method

Starts an OLE drag/drop event with the given control as the source.

Return Type

A Boolean value.

Syntax

object.OLEDrag

The OLEDrag method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.


Acceleration property (UpDown)

Get/Set the rate at which the value (position) changes

Property type

A No Return Value value.

Syntax

object.Acceleration(rhs As Integer) [= value]

The Acceleration property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


Alignment property (UpDown)

Get/Set the alignment of the UpDown control with its buddy control

Property type

A No Return Value value.

Syntax

object.Alignment(rhs As AlignmentConstants) [= value]

The Alignment property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


AutoBuddy property (UpDown)

Get/Set the auto-buddy flag, to automatically select the buddy control

Property type

A No Return Value value.

Syntax

object.AutoBuddy(rhs As Boolean) [= value]

The AutoBuddy property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


BuddyControl property (UpDown)

Get/Set the control for use as a buddy control

Property type

A No Return Value value.

Syntax

object.BuddyControl(rhs As Variant) [= value]

The BuddyControl property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


BuddyProperty property (UpDown)

Get/Set which property to use to sync with Buddy Control

Property type

A No Return Value value.

Syntax

object.BuddyProperty(rhs As Variant) [= value]

The BuddyProperty property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


Enabled property (UpDown)

Returns/sets a value that determines whether a form or control can respond to user-generated events.

Property type

A No Return Value value.

Syntax

object.Enabled(rhs As Boolean) [= value]

The Enabled property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


hWnd property (UpDown)

Returns a handle to a form or control.

Property type

A OLE_HANDLE value.

Syntax

object.hWnd [= value]

The hWnd property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A OLE_HANDLE value.


Increment property (UpDown)

Get/Set the amount by which the position changes on each click

Property type

A No Return Value value.

Syntax

object.Increment(rhs As Long) [= value]

The Increment property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


Max property (UpDown)

Get/Set the upper bound of the scroll range

Property type

A No Return Value value.

Syntax

object.Max(rhs As Long) [= value]

The Max property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


Min property (UpDown)

Get/Set the lower bound of the scroll range

Property type

A No Return Value value.

Syntax

object.Min(rhs As Long) [= value]

The Min property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


OLEDropMode property (UpDown)

Returns/Sets whether this control can act as an OLE drop target.

Property type

A OLEDropConstants value.

Syntax

object.OLEDropMode [= value]

The OLEDropMode property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A OLEDropConstants value.


Orientation property (UpDown)

Get/Set the vertical/horizontal orientation of the control

Property type

A No Return Value value.

Syntax

object.Orientation(rhs As OrientationConstants) [= value]

The Orientation property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


SyncBuddy property (UpDown)

Get/Set the flag to have the buddy control kept in sync

Property type

A No Return Value value.

Syntax

object.SyncBuddy(rhs As Boolean) [= value]

The SyncBuddy property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


Value property (UpDown)

Get/Set the current position in the scroll range

Property type

A No Return Value value.

Syntax

object.Value(rhs As Long) [= value]

The Value property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.


Wrap property (UpDown)

Get/Set whether the value (position) will wrap from max to min (or min to max)

Property type

A No Return Value value.

Syntax

object.Wrap(rhs As Boolean) [= value]

The Wrap property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type UpDown.
value | A No Return Value value.